Virtualmin ionCube Install

[b]Read the whole post before you do anything…[/b]

There are a few versions of the loader in the tar archive. Use the one that matches your PHP version. Im in a Linux Ubuntu 10.10 Using Virtualmin:

  1. Download: sudo wget http://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.ta…
  2. Extract: sudo tar zxvf ioncube_loaders_lin_x86.tar.gz
  3. Move to a permanent location: sudo mv ioncube /home/blablabla/public_html
  4. Move ‘ioncube_loader_lin_5.3.so’ to: /usr/lib/php5/20090626+lfs
  5. Move ’20ioncube.ini’ to: /etc/php5/cgi/conf.d
  6. Add reference to your php.ini file: zend_extension = /home/blablabla/public_html/ioncube/ioncube_loader_lin_5.3.so
  7. Or: sudo pico /etc/php5/apache2/php.ini and add: zend_extension = /usr/local/lib/ioncube/ioncube_loader_lin_5.3.so
  8. Restart apache: sudo /etc/init.d/apache2 restart
  9. Test installation by visiting the URL: http://blablabla.com/ioncube/loader-wizard.php

NOTE: I also had to install Curl to use with a script and Paypal, here is how: – sudo apt-get install php5-curl – sudo service apache2 restart

Here are the Original Instructions to Install ioncube loader on Ubuntu 10.04 Lucid, PHP 5.3:

  1. Download ionCube loaders: sudo wget http://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.ta…
  2. Extract: sudo tar zxvf ioncube_loaders_lin_x86.tar.gz (loader-wizard.tgz)
  3. Move to a permanent location: sudo mv ioncube /usr/local/lib/
  4. Add reference to your php.ini file: sudo pico /etc/php5/apache2/php.ini
  5. Restart apache: sudo /etc/init.d/apache2 restart
  6. Test installation: http://blablabla.com/ioncube/loader-wizard.php

Or here is my Short Version: Copy the ionCube folder to your public_html folder Copy: ioncube_loader_lin_5.3.so to: /usr/lib/php5/20090626+lfs (you may need to use ‘gksu nautilus’ command to do this) Copy: 20ioncube.ini to: /etc/php5/cgi/conf.d Add the following line to: Virtualmin -> Services -> PHP 5 Configuration, right below [PHP]: zend_extension = /home/blablabla/public_html/ioncube/ioncube_loader_lin_5.3.so